REGISTER  


Mplayer: Unsupported PixelFormat -1
This thread belongs to expert.forumgeeks.net


2009-05-25 17:20 GMT   |   #1
 
Hi all,

I'm trying to watch Kill Bill Vol. 1 on my Slackware 12.2 box.
I have Mplayer installed, and also this package supposed to contain
all possible codecs:
http://repository.slacky.eu/slackware-12.2/multimedia/all/20071007/all...071007-

When I try to play a .VOB file on the dvd, the error
"Unsupported PixelFormat -1"
comes out.

Any suggestions?
Thanks
2009-05-25 17:20 GMT   |   #2
 
....from command line:

root@darkstar:~# mplayer /mnt/dvd/VIDEO_TS/VIDEO_TS.VOB
MPlayer SVN-r29169-4.2.4 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote
control.

Playing /mnt/cdrecorder/VIDEO_TS/VIDEO_TS.VOB.
MPEG-PS file format detected.
MPEG: No audio stream found -> no sound.
VIDEO: MPEG2 720x576 (aspect 2) 25.000 fps 8000.0 kbps (1000.0
kbyte/s)
[VO_XV] Could not grab port 65.
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed Sad
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12
V: 0.3 6/ 6 ??% ??% ??,?% 0 0

Exiting... (End of file)
2009-05-25 17:43 GMT   |   #3
 
I get this as well with the svn builds of mpayer. It is, I think, a ffmpeg (for recent svn to be used
with svn mplayer) issue for a change that occured in

/usr/include/libavutil/pixfmt.h

I had to add the old PIX_FMT includes to be able to compile libquicktime and kino as they
complained about missing the following, which I added after installing ffmpeg:

#define PIX_FMT_UYVY411 PIX_FMT_UYYVYY411
#define PIX_FMT_RGBA32 PIX_FMT_RGB32
#define PIX_FMT_YUV422 PIX_FMT_YUYV422

Now mplayer and its gui complain about invalig pixelformat put the videos play just fine. Other
mplayer frontends don't display/log the error (such as gnome-mplayer).

2009-05-26 07:20 GMT   |   #4
 
I already have this in /usr/include/libavutil/pixfmt.h:

....
#if LIBAVUTIL_VERSION_INT < (50<<16)
#define PIX_FMT_UYVY411 PIX_FMT_UYYVYY411
#define PIX_FMT_RGBA32 PIX_FMT_RGB32
#define PIX_FMT_YUV422 PIX_FMT_YUYV422
#endif
....

Anything else I can check? Thanks.
2009-05-26 07:20 GMT   |   #5
 
Do you always run mplayer as root while reading a ripped file in
/mnt/dvd/VIDEO_TS/VIDEO_TS.VOB
or is that the kill bill dvd mounted?

Why don't you just do a mplayer dvd://
2009-05-26 11:20 GMT   |   #6
 
Not sure but you may try on other output driver :
mplayer -vo help
Which xorg driver are you using ?
try : grep -Hi driver /etc/X11/xorg.conf 
2009-05-26 11:20 GMT   |   #7
 
Yes, it was mounted and I was root.

dvd:// is a good trick!
This is what happens:

--------------------------
root@darkstar:~# mplayer dvd://
MPlayer SVN-r29169-4.2.4 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote
control.

Playing dvd://.
libdvdread: Encrypted DVD support unavailable.
There are 5 titles on this DVD.
There are 1 angles in this DVD title.
audio stream: 0 format: ac3 (5.1) language: en aid: 128.
audio stream: 1 format: ac3 (5.1) language: it aid: 129.
audio stream: 2 format: dts (5.1) language: it aid: 138.
number of audio channels on disk: 3.
subtitle ( sid ): 0 language: en
subtitle ( sid ): 1 language: en
subtitle ( sid ): 2 language: it
subtitle ( sid ): 3 language: en
subtitle ( sid ): 4 language: it
number of subtitles on disk: 5


Exiting... (End of file)
--------------------------

At this point, after googling around "libdvdread: Encrypted DVD
support unavailable.", I installed libdvdcss.

Now Uma Thurman is kicking ass! Thanks a lot everybody!
2009-05-26 11:20 GMT   |   #8
 
root@darkstar:~# mplayer -vo help
MPlayer SVN-r29169-4.2.4 (C) 2000-2009 MPlayer Team
Available video output drivers:
xv X11/Xv
x11 X11 ( XImage/Shm )
xover General X11 driver for overlay capable video output
drivers
gl X11 (OpenGL)
gl2 X11 (OpenGL) - multiple textures version
dga DGA ( Direct Graphic Access V2.0 )
sdl SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
fbdev Framebuffer Device
fbdev2 Framebuffer Device
svga SVGAlib
aa AAlib
caca libcaca
v4l2 V4L2 MPEG Video Decoder Output
xvidix X11 (VIDIX)
cvidix console VIDIX
null Null video output
mpegpes MPEG-PES to DVB card
yuv4mpeg yuv4mpeg output for mjpegtools
png PNG file
jpeg JPEG file
gif89a animated GIF output
tga Targa output
pnm PPM/PGM/PGMYUV file
md5sum md5sum of each frame

root@darkstar:~# grep -Hi driver /etc/X11/xorg.conf
/etc/X11/xorg.conf: Driver "kbd"
/etc/X11/xorg.conf: Driver "mouse"
/etc/X11/xorg.conf: ### Available Driver options are:-
/etc/X11/xorg.conf: Driver "nv"

Thanks!
2009-05-27 00:02 GMT   |   #9
 
You may have to get rid of the #if LIBAVUTIL_VERSION_INT < (50<<16) check since that buggers
some compiles for multimedia apps (at least for me). IIRC these PIX_FMT are being deprecated but
some aps still expect them. Hence, for certain mpeg stream run through mplayer (and therefore
ffmpg) you get the Pixelformat error. So far it hasn't stopped me from viewing the mpeg1. mpeg2
(as in DVD) or mpeg4 videos. Its just annoying as hell and I haven't figured out how to get rid of it.