REGISTER  


Debian - Sound playing through the speaker, rather than the sound card
This thread belongs to expert.forumgeeks.net


2009-08-29 23:20 GMT   |   #1
 
I have reinstalled Debian onto one of my computers, and now when I play
a music file, the sound comes out of the pc speaker rather than being
played through the sound card. The same computer used to operate
normally in the past.

It is as if some sort of sound card emulation is running.

lspci|grep snd reveals:

snd_pcm_oss 32544 0
snd_mixer_oss 12288 1 snd_pcm_oss
snd_via82xx 20248 0
gameport 10504 3 ns558,snd_via82xx
snd_ac97_codec 88228 1 snd_via82xx
ac97_bus 1664 1 snd_ac97_codec
snd_pcsp 8220 0
snd_pcm 60680 4
snd_pcm_oss,snd_via82xx,snd_ac97_codec,snd_pcsp
snd_timer 17668 1 snd_pcm
snd_page_alloc 7816 2 snd_via82xx,snd_pcm
snd_mpu401_uart 6400 1 snd_via82xx
snd_rawmidi 18592 1 snd_mpu401_uart
snd_seq_device 6412 1 snd_rawmidi
snd 44964 10
snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_ac97_codec,snd_pcsp,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 6112 1 snd
2009-08-30 00:05 GMT   |   #2
 
Your sound chip has an output to the internal speaker. Personally I
think it's a neat feature of motherboards that have it. If you just
want desktop sounds, not hi-fi audio, you don't need external speakers.

alsamixer, or whatever Debian uses, should allow you to select the
output, like mute the speaker and unmute the line out (for your external
speakers).
2009-08-30 05:20 GMT   |   #3
 
The sound is very very quiet and scratchy, as if the sound is not
supposed to come from there. You know if you have a hifi on full blast, but no
speakers attached, and you can hear music coming from the circuit board.
It sounds like that.

The installer has changed a setting. This machine worked from Sarge
through to Lenny, but not with a fresh Lenny install.


The mixer controls now only offer the volume control slider. The other
output controls are greyed out.

2009-08-30 08:48 GMT   |   #4
 
Remove or blacklist "snd_pcsp." That sends sound through the PC speaker.
2009-08-30 09:20 GMT   |   #5
 
I have blacklisted the snd_pcsp module, and now the sound system
operates normally.