REGISTER  


100% CPU usage of Xorg after 15 minutes
This thread belongs to expert.forumgeeks.net


2008-12-27 13:20 GMT   |   #1
 
I have updated my system from OpenSUSE 10.3 to OpenSUSE 11.1.
Before, it worked OK (never touch a working system...)

Now, the X server has a problem. After not touching the mouse and keyboard
for about 15 minutes, the CPU usage of the X server jumps to 100%.
This can be seen in "top" running from another system over SSH.
It can also be seen in the CPU graph of "gkrellm" running on the system.
I see the CPU use of one code step to 100% after some time, and when I
touch the mouse or keyboard it falls back to 0 again.

Videocard is NVIDIA 8500GT, NVIDA driver 177.82 has been installed from
the NVIDIA repository.
I would like to try the newer 180.xx beta driver but I see no way to install
it from the repository.

Anyone else seen this problem? And has it occurred on 11.0 as well?
Better yet: how can this be solved?
2008-12-27 13:20 GMT   |   #2
 
Probably the screensaver. Disable it and test again.
2008-12-27 13:20 GMT   |   #3
 
I had no screensaver, and I had already re-checked that it was disabled.
Sorry I did not mention that...

In fact I have even uninstalled the screensaver package. Now, in the
desktop settings it only offers the "blank screen" and "random" settings.
But still there is no difference.
2008-12-27 15:20 GMT   |   #4
 
I upgraded 10.3 with 11.1 RC2 and I noticed the higher cpu usage when
testing 11.1RC2. There's definitely something amiss with the 10.3 to
11.1 upgrade. I did a clean install of 11.1 wiping out the 11.1RC2/10.3
upgrade and the cpu usage problem went away. There's lots of other
problems with 11.1 but it's running smoother than the 11.1RC2 upgrade.

BTW, I have / (root) and /home on separate partitions so I only needed to
format the /.
2008-12-27 15:20 GMT   |   #5
 
Thanks, I will find out what is the difference between these approaches.
Maybe something is different in xorg.conf...
2008-12-28 05:20 GMT   |   #6
 
check around (i don't have time right this second to do so for you)
but i believe the DEFAULT start time for several system cron jobs is
15 minutes after boot (*IF* it missed the last scheduled at (say)
midnight because the system was OFF)..

maybe that is what is going on there....does it settle down again
after (say) boot plus 30 minutes??
2008-12-28 09:20 GMT   |   #7
 
Why would cron jobs, none of which ever run under an X11 windowing system
to the best of my knowledge, affect the CPU usage of the X server?

Rob clearly stated that

"the CPU usage of the X server jumps to 100%.
This can be seen in "top" running from another system over SSH."
2008-12-28 10:06 GMT   |   #8
 
I have the same exact issue happening on a laptop with 11.1, while it never
happened on 11.0. Interestingly enough, it turned out to be related to
kded4 process, despite the fact that I use kde3. The darn kde suse update
applet seems to require kde4 libs.

See if this helps, next time it happens: 'pkill kded4'.
2008-12-29 11:01 GMT   |   #9
 
rob wrote:
Anyone else seen this problem? And has it occurred on 11.0 as well?



Yes, and not on 11.0. Appearancee is random (i.e., not at 15 minutes). I
am also using NVidia graphics adapters; two cards with two monitors
each. x11-video-nvidiaG02-177.82. x86_64 install.

I will try Dominik's suggestion this evening.

Since installing 11.1, I am additionally having a frequently occurring
problem where X stops responding to mouse clicks, requiring termination
and restart of the X session. I have been using KDE 3, since KDE 4
appeared to have difficulties in Xinerama mode.
2008-12-31 05:20 GMT   |   #10
 
earlier i assummed that you had already killed the beagle, but did you??

1 2nextlast