REGISTER  


LXDE desktop and YaST
This thread belongs to expert.forumgeeks.net


2009-05-03 03:20 GMT   |   #1
 
I'm trying out this light weight desktop environment LXDE.
I installed it in 11.1 via 1-click and that went without any problems.

YaST is launched not like YaST in konsole or KDE but as separate modyles
like for example:
System > Administration > Software Management.

When the module opens a pop-up warns about needing root privileges and
if continued the module may not function properly and stuff.

I haven't found a way to give root password.

Has anybody tried LXDE? It looks quite nice and responsive on an old
box.

All this investigation is because I'm afraid I'll have to let KDE go
soon...
2009-05-03 14:15 GMT   |   #2
 
I have not tried it. However, with regards to KDE,
YaST is executed by default with kdesu. You CAN configure kdesu
to use sudo instead of su and then configure yourself rights under
sudo so that a person will have the role to do administrative things
(e.g. a wheel group style of behavior).

So... not sure about LXDE... you'll have to look into whether
or not it uses some kind of privilege escalation front end what
its options might be.

But since LXDE is becoming a popular option, let us know if you
find out and what your solution is.
2009-05-03 22:41 GMT   |   #3
 
Did you look behind and under the pop-up windows for the password prompt
box? I remember this happening to me, I finally found the password
box, it had just came-up behind some other windows there when I was
installing something else, it wasn't LXDE.
2009-05-04 13:20 GMT   |   #4
 
Vahis, where did you install it in 1 click? I had to go directly here:
http://download.opensuse.org/repositories/home:/swyear:/lxde/openSUSE_11.1/
and click on 'LXDE...ymp' and let the YaST Meta [something] do the rest.

I installed the LXDE, but could not find the "Software Management" menu.
I clicked on the YaST icon on the desktop (the icons are from the KDE 4.2).
A pop-up shows only a few sub-modules: Software (Media Check, Online Update
Configuration), Network Services (LDAP Browser), Support (Release Notes,
Support Registration). While this crippled YaST pop-up is on, the bar
at the bottom (task bar? with icons for the menu, Firefox, etc.) goes
blank (white) and blinks intermittently. This blinking does not happen
with Firefox, Thunderbird, or mlterm.
And there was no pop-ups for me warning about root privileges.

So, I do what I often do in whatever DTE or window manager; launch a
terminal, "su -", and the complete YaST pop-up comes up. I've just
updated some packages.

I have a few DTE and window managers installed: AfterStep,
Enlightenment, Blackbox, Fluxbox, twm, Peckwm, jwm, awesome, KDE 4.2,
Gnome, wmii, XFCE(?). wmii is very minimalist; I find it quite
interesting. I may choose it as a platform for serious work.

On the Mepis 8.0, I've just installed 9wm and wm2 (besides wmii, KDE
3.5, awesome, blackbox, fluxbox, jwm, Peckwm). Mepis (Debian-based now)
seems solid (if somewhat boring), and offers lots of window managers;
maybe, LXDE is a click or two away.
2009-05-06 13:20 GMT   |   #5
 
chris_cox: I haven't found a real solution.
I think it's some stuff that is wrong or missing from LXDE packages.
No wonder, it's in an early stage.

I've been using some workarounds and stuff, I will put something on line
soon about my experiments.

Since LXDE still works quite nicely I've been struggling to find a way to
install just LXDE, not installing it on top of like KDE or Gnome.

I've startded from text mode, without X and then investigated what needs
to be done to run pure LXDE.

It doesn't seem to be possible, it needs stuff that in our case
(openSUSE) is in KDE and Gnome. That's the problem when those two are so
tangled together with the openSUSE graphical environment.

I just wish I'd find some pointers to what it really needs.
A lot seems to come along just because of the distribution dependencies.